Search

Page 1 of 3 (27 items) 1 2 3 Next >
  • I/O gear for MC 2023 on MAC M2

    I'm currently running MC 2023.12 on my 2023, 16" M2 MBPro with no problems at all. But I'd like to add I/O gear to send picture to a client monitor, and sound to external speakers. In the paast, I've used AJA and Blackmagic devices, but I'm seeing some feeedback online that the currrent versions aren't compatible with MC on
    Posted to Avid Media Composer - Mac (Forum) by plnorden on Wed, Feb 14 2024
  • Re: Native MC for Apple Silicon

    Well, I can only reference my specific situation. I'm using MC 2023.8.2 on a 2023 MacBook Pro 16" M2 Pro w 32GB RAM, running Ventura 13.5. Currently ediitng a feature film with 2K dailies off of an externa USB-C hard drive. No peripherals or I/O gear. It has been 100% rock solid.
    Posted to Avid Media Composer - Mac (Forum) by plnorden on Fri, Dec 8 2023
  • Re: Please help... Best MACBOOK PRO for Avid MC in 2023?

    I recently took the plunge and finally upgraded from my trusty 2017 15" MacBook Pro Retina. I purchased a 16" M2 MacBook Pro. Currently running Avid 2023.8.2 on Ventura 13.5. I primarily cut indie freatures and this set up has been working flawlessly. I exprienced an initial bug invloving dragging with segement mode in the timeline with 2023
    Posted to Avid Media Composer - Mac (Forum) by plnorden on Sat, Nov 18 2023
  • Re: Advise on minimum RAM for a new Macbook

    I'm in this exact same situation. I pretty much only edit feature films and narrative longform, with dailies transcoded to 1080P. I plan to get a new M2 16" MacBook Pro pretty soon, but I'm going for the base level stock configuration with 16GB RAM. Why? Because I'm upgrading from my current laptop which is a 2015 Retina MacBook Pro
    Posted to Avid Media Composer - Mac (Forum) by plnorden on Sun, Aug 13 2023
  • Re: Editing with audio recorded to camera

    Thansk to everyone for all of these replies! This feedback pretty much syncs (pun intended) with my concerns too. I'm walking into an existing workflow, and there are several other things that IMHO need to be changed, so just wasn't sure if I wanted to rock the boat about this too...
    Posted to General Discussion & Off-Topic (Forum) by plnorden on Sun, May 7 2023
  • Re: Editing with audio recorded to camera

    Yup, that was my feeling on the matter. I just couln't think of any obvious "gotcha", as long as all channels are being replicated and there's no loss of quality...
    Posted to General Discussion & Off-Topic (Forum) by plnorden on Sun, May 7 2023
  • Editing with audio recorded to camera

    I’m gearing up to edit a low budget feature film for some first time filmmakers. They plan to send audio from the sound mixer to be recorded in camera as they shoot, in addition to a field recorder. The idea is to edit with the camera audio to save time in syncing and organizing. The seperate audio tracks would just be a backup, and ideally identical
    Posted to General Discussion & Off-Topic (Forum) by plnorden on Fri, May 5 2023
  • 2015 MacBook Pro not supported?

    I just loooked at the list of qualified Mac systems along with the new 2021.2 update, and no longer see my trusty 15" mid-2015 Retina MacBook Pro on the list. Is this machine really no longer supported?
    Posted to Avid Media Composer - Mac (Forum) by plnorden on Mon, Feb 22 2021
  • Autosync using inpoints not working anymore!

    I'm starting a new film project and find that I can't autosync clips using inpoints. Despite selecting my audio and video clips and choosing "inpoints" as the type of sync for aautosync, I still get an error message about mismatched timecode. The software seems to be ignoring my selection and sticking with the default choice of timecode
    Posted to Avid Media Composer - Mac (Forum) by plnorden on Thu, Dec 5 2019
  • Re: audio import and linking weirdness

    "Makes me think somehow the monophonic wav files are triggering BWF-like behavior." Yup, that's what's happening all right. But also with aiffs. I actually just tried linking to some SD2 files that I've got in my library, and those link and import normally. Go figure. I've already reset my user, project and site settings..
    Posted to Avid Media Composer - Mac (Forum) by plnorden on Thu, Oct 8 2015
Page 1 of 3 (27 items) 1 2 3 Next >

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller