Latest post Wed, Sep 14 2022 7:48 PM by volkersm. 11 replies.
Page 1 of 1 (12 items)
Sort Posts: Previous Next
  • Sun, Feb 28 2021 9:35 PM

    • Tom Cook
    • Top 500 Contributor
    • Joined on Sun, Apr 25 2010
    • Keene, NH
    • Posts 250
    • Points 3,130

    AVID Link Won't run/open

    Folks:

    After finding out I can't have a licensed Avid Media Composer running/installed simultaneous with AMC First, I installed First on a low-end laptop (my students are using AMC-F so I need to be conversant with the somewhat different workspace). Trouble is after (apparently successfully installing First when I try to run Avid Link (to authorize the install) the Windows icon spins for a while (like Link is going to run) and then - nothing. 

    Suggestions? Thanks.

    Tom

    Dell XPS720, quadcore 3.6 GHz, 28 GB RAM, Avid Media Composer v8.7.2 [view my complete system specs]
  • Wed, Mar 3 2021 11:12 AM In reply to

    • RalphC
    • Top 50 Contributor
    • Joined on Wed, Sep 2 2015
    • Posts 2,932
    • Points 32,370

    Re: AVID Link Won't run/open

    Hi Tom,

       Sorry to hear this, is that the latest Avid Link app? What OS version?

     

     

    RalphC

    MacBook Pro 15 2018 Intel Core i7 2.6GHz Mac 10.15.7 Intel UHD 630. [view my complete system specs]
  • Wed, Mar 3 2021 4:39 PM In reply to

    • Tom Cook
    • Top 500 Contributor
    • Joined on Sun, Apr 25 2010
    • Keene, NH
    • Posts 250
    • Points 3,130

    Re: AVID Link Won't run/open

    Ralph: Thanks for the assist. I'm trying to run it on a laptop with Windwos 10. Not sure what version Link (since it won't open) but I installed it from the latest Avid download "Media Composer 21.2.0"...

    Tom

    Dell XPS720, quadcore 3.6 GHz, 28 GB RAM, Avid Media Composer v8.7.2 [view my complete system specs]
  • Fri, Mar 5 2021 2:18 PM In reply to

    • RalphC
    • Top 50 Contributor
    • Joined on Wed, Sep 2 2015
    • Posts 2,932
    • Points 32,370

    Re: AVID Link Won't run/open

    The first thing that I recommend you check is the Windows Firewall, be sure you allow the Avid Link app through the firewall. Also, you need to run the Avid Link on an Administrator account. Check out this FAQ for other Avid Link network troubleshooting steps.

     

     

    RalphC

    MacBook Pro 15 2018 Intel Core i7 2.6GHz Mac 10.15.7 Intel UHD 630. [view my complete system specs]
  • Fri, Mar 5 2021 2:27 PM In reply to

    • Tom Cook
    • Top 500 Contributor
    • Joined on Sun, Apr 25 2010
    • Keene, NH
    • Posts 250
    • Points 3,130

    Re: AVID Link Won't run/open

    Thanks, Ralph. Will try that today and get back asap... Have a good weekend.

    TC

    Dell XPS720, quadcore 3.6 GHz, 28 GB RAM, Avid Media Composer v8.7.2 [view my complete system specs]
  • Sat, Mar 6 2021 12:06 AM In reply to

    • Tom Cook
    • Top 500 Contributor
    • Joined on Sun, Apr 25 2010
    • Keene, NH
    • Posts 250
    • Points 3,130

    Re: AVID Link Won't run/open

    My account IS Administrator status...

    I disabled the Windows Firewall and tried to launch Link with the same result - spinning icon and then zilch...

    Read through the FAQ and didn't see anything germane to my situation...

    Any other ideas?

    Thanks.

    TC

    Dell XPS720, quadcore 3.6 GHz, 28 GB RAM, Avid Media Composer v8.7.2 [view my complete system specs]
  • Sat, Mar 27 2021 2:58 AM In reply to

    • Chris Paul
    • Not Ranked
    • Joined on Sat, Jan 7 2012
    • Posts 5
    • Points 45

    Re: AVID Link Won't run/open

    I'm having the same problem.  Did you ever resolve?

    Thanks!

     

  • Sat, Mar 27 2021 11:03 AM In reply to

    • Tom Cook
    • Top 500 Contributor
    • Joined on Sun, Apr 25 2010
    • Keene, NH
    • Posts 250
    • Points 3,130

    Re: AVID Link Won't run/open

    Chris:

    Do you have ANY other version of Avid installed on your system? I have the fully-licensed Media Composer which I use for my personal projects but also teach editing at a local college. As such, I had hoped to have my students install Media Composer First (since it's free) to learn the basic Avid program - so I'd planned to install MCF on my system, too, so I could walk them through the exact same screens, etc.

    As another forum user pointed out as I was having my own issues (and I found true) you cannot simultaneously install MCF and any other version of Avid or Link won't run/connect. When I installed MCF on a laptop that was clean, Link ran fine...

    Hope this helps.

    TC

    Dell XPS720, quadcore 3.6 GHz, 28 GB RAM, Avid Media Composer v8.7.2 [view my complete system specs]
  • Sat, Mar 27 2021 11:36 AM In reply to

    Re: AVID Link Won't run/open

    The MC First and the Regular MC install are the same software. Its the same code. Avid link and your licensing are what determines how MC launches and operates.

    The issues seem to be that Avid Link can't handle having both options available to you.

    I've got stuck having installed MC First and then trying to run regular MC. It just kept running MC First. I had to unistall Avid. Delete all the related files manually and re-install to resolve. ( I think I now know what the actual files I needed to delete were) 

    HP Z840 3.1GHZ 20cores 128GB RAM M4000 GPU 1TB NVMe drive HP Z book 17 G2 2.7GHZ Quad core 32GB RAM Nvidia K3100M 1TB SSD drive ACI Moderator. I'm... [view my complete system specs]

     

    Broadcast & Post Production Consultant / Trainer  Avid Certified Instructor VET (Retired Early 2022)

     

    Still offering training and support for: QC/QAR Training - Understanding Digital Media - Advanced Files * Compression - Avid Ingest - PSE fixing courses and more.

    Mainly delivered remotely via zoom but onsite possible.

     

    T 07581 201248 | E [email protected]

     

  • Tue, Dec 21 2021 12:22 AM In reply to

    Re: AVID Link Won't run/open

    My avid link won't work either. A constant issue. So inconsistent. Saying there's no server. 

  • Wed, Dec 22 2021 5:26 PM In reply to

    • RalphC
    • Top 50 Contributor
    • Joined on Wed, Sep 2 2015
    • Posts 2,932
    • Points 32,370

    Re: AVID Link Won't run/open

    Aeronleslie:

    My avid link won't work either. A constant issue. So inconsistent. Saying there's no server. 

     What OS are you using?

     

     

    RalphC

    MacBook Pro 15 2018 Intel Core i7 2.6GHz Mac 10.15.7 Intel UHD 630. [view my complete system specs]
  • Wed, Sep 14 2022 7:48 PM In reply to

    • volkersm
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Sioux Center, IA
    • Posts 3
    • Points 45

    Re: AVID Link Won't run/open

    I have 18 stations running Avid Media Composer and I can't access Avid Link on any of them. Therefore, I can't update Media Composer and on some of the machines, I can't run MC until I log into LINK so it can check my licenses.

    Anyone have a solution? Thanks. 

     

    32.0 GB Ram

    64 Bit 

    Intel Xeon E-2176G CPU @ 3.70GHZ

    Windows 10 Edu

    Media Composer 2012

    HP xw8200 Media Composer 3.0 Avid DVD by Sonic 5.7 After Effects 7.0 Nvidia Quadro FX 1400 Windows XP [view my complete system specs]

     

    Filed under: ,
Page 1 of 1 (12 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller