Latest post Tue, Sep 20 2016 7:50 PM by Joachim Claus. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • Tue, Sep 20 2016 8:04 AM

    • Joachim Claus
    • Top 150 Contributor
    • Joined on Fri, Nov 4 2005
    • Seeheim-Jugenheim, Germany
    • Posts 948
    • Points 12,245

    AAF-Export does not export Audio Track A1

    I reported this issue some time ago and thought, that I solved it. See http://community.avid.com/forums/p/160143/808148.aspx#808148

    However, this is not the case. Actually when I use AAF-export with copies of all media to a folder, it only exports Audio Track 2 but not Audio Track 1.

    I made a small test as follows:

    1. Created a UHD50p project.
    2. Linked to three UHD clips, and transcoded them to DNxHR SQ.
    3. I created a timeline and placed the three clips on it.
    4. I run AAF-Export to a folder with options "copy all media" for video and audio. While the export progresses it says: Exporting File 1 of 9 .....  Exporting File 9 of nine.
    5. If I check the export-folder, it only contains six files, with audio track A1 missing for all clips.

    I repeated the test in a 1080p50 project, and in a 720p50 project and got the same results, Audio Track A1 is missing.

    I hope, that someone can confirm this, or identify a faulty procedure on my side.

    Joachim

    AAF-Setting

    SuperMicro Workstation 7048A-T Dual Xeon (10 cores) E5-2640v4 2.4GHz 128 GB RAM, PNY P4000, 1 PCIe SSD 400 GB (Intel SSDPEDMW400G4) 1 SSD 2 TB for UHD... [view my complete system specs]

    Joachim Claus

  • Tue, Sep 20 2016 9:10 AM In reply to

    • fsm
    • Not Ranked
    • Joined on Tue, Nov 24 2009
    • Germany
    • Posts 186
    • Points 2,270

    Re: AAF-Export does not export Audio Track A1

    you marked track 1 in timeline?

    MC 2023.03 & SYM / BM Monitor4K / Windows 11 64 bit / i7 12700k / RTX3070 [view my complete system specs]
  • Tue, Sep 20 2016 11:17 AM In reply to

    • Joachim Claus
    • Top 150 Contributor
    • Joined on Fri, Nov 4 2005
    • Seeheim-Jugenheim, Germany
    • Posts 948
    • Points 12,245

    Re: AAF-Export does not export Audio Track A1

    fsm:

    you marked track 1 in timeline?

    Yes, all tracks are marked, and In-, Out-points were set.

    My further investigation has shown, that it only happens with seperate disks for video and audio and transcoding in background. If I transcode the source clips to a single disk, the AAF-export works fine. If I transcode to seperate disks, but not in background, AAF-export is fine.

    I investigated the naming of the media files, and names differ, depending on whether media are stored on seperate disks for audio and video, or whether they are stored on the same  disk, and further more, they differ, depending on whether transcoding in background or not.

    Here is the screenshots from the media tool with same files in different transcode modes:

     As you cann see from the screenshot, the naming of the two audio files is of a clip is totally different in the case of transcoding to separate disks and running in background  from the other two cases.  

    In the first case (transcoding in BG to different disks) either transcode fails in regard of the naming convention, or AAF-Export fails because it does not recognize the naming for audio 1.

    In the other two cases (transcoding in BG to the same disk, and transcoding in foreground to separate disks) the two audio-files have dinstinctive naming. In the case of foreground transcoding to different disks the names start with 0A01 for audio 1, 0A02 for audio 2 (and 0V01 for video). In the case of transcoding in BG to the same disk audio 1 and audio 2 are named with the terms .1, and .2 at the end of the file ID. Both cases lead to correct handling with AAF-export.

    I hope, that an expert from Avid will read this and initiate a repair.

    Joachim  

    SuperMicro Workstation 7048A-T Dual Xeon (10 cores) E5-2640v4 2.4GHz 128 GB RAM, PNY P4000, 1 PCIe SSD 400 GB (Intel SSDPEDMW400G4) 1 SSD 2 TB for UHD... [view my complete system specs]

    Joachim Claus

  • Tue, Sep 20 2016 2:19 PM In reply to

    • Marianna
    • Top 10 Contributor
    • Joined on Thu, Oct 13 2005
    • Avid
    • Posts 11,882
    • Points 259,615
    • ! Avid Employee
      !Avid Customer Advocate
      Avid Beta Moderators
      Avid Developer Moderator
      ForumsAdministrator
      Moderator: Edit on Demand
      Moderator: SSAI PHAI
      SystemAdministrator

    Re: AAF-Export does not export Audio Track A1

    Got it Joachim....

    Case # 03041050 - they will try to reproduce and respond back shortly.

    Marianna

    Sr. Director | Customer Experience and Community [view my complete system specs]
  • Tue, Sep 20 2016 7:50 PM In reply to

    • Joachim Claus
    • Top 150 Contributor
    • Joined on Fri, Nov 4 2005
    • Seeheim-Jugenheim, Germany
    • Posts 948
    • Points 12,245

    Re: AAF-Export does not export Audio Track A1

    Thank you Marianna. I am looking forward to supporting your experts.

    I have looked deeper into the naming of the files, and considered the folder, to which I made the AAF-export. In the case "Transcoding in BG to different disks" the two files for Video and for Audio 1 have exactly the same name. Tis does not matter, as long as the files stay on different disk-volumes. However AAF-export to a single folder must struggle. It copies the video file first, then followed by audio file 1, and finally audio file 2 to the defined folder. When the video file has been copied, the audio file 1 cannot be copied without creating collision with the video file due to the same name. The operating system (Windows 10) will block the copy as a file with this name already exists, and sends an error message to the initiating program.

    Summery: The naming convention for background transcoding to separate disks for video and audio is wrong, as it defines identical names for video and for audio 1.

    Joachim

    SuperMicro Workstation 7048A-T Dual Xeon (10 cores) E5-2640v4 2.4GHz 128 GB RAM, PNY P4000, 1 PCIe SSD 400 GB (Intel SSDPEDMW400G4) 1 SSD 2 TB for UHD... [view my complete system specs]

    Joachim Claus

Page 1 of 1 (5 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller