Latest post Fri, Feb 20 2015 5:56 PM by AnthonyAmmo. 5 replies.
Page 1 of 1 (6 items)
Sort Posts: Previous Next
  • Wed, Feb 18 2015 2:47 PM

    Workaround for "Exception: DecompStream::GetFinishedFrame Corrupt frame detected"?

    Hoping somebody can help with this. I'm not working at the specs in my signature. I'm on 6.5.4.5 at a facility.

     

    I've been bringing in a ton of footage from the Canon C300. The source is MXF media, structured so that each clip is contained in its own folder with additional data.

     

    On this particular card, when I playback my AMA links I will get an error message every few dozen seconds that reads:

     

    Exception: DecompStream::GetFinishedFrame Corrupt frame detected in filename frame x of sequence error codec CMError_Codec

     

    The error still comes up after consolidating the footage. Same with transcoding. I've gone back and checked the original file on the shuttle drive from before transferring to our edit drive, but it's still happening there. I've also tried these things in my MC8 with the same results.

     

    I tried placing the footage into a sequence and then exporting as ProRes but the export failed. I also tried converting in compressor, but it looks like that program cannot bring in MXF files.

     

    The MXF files playback seemlessly in VLC, which is why I was hoping a simple conversion would work.

     

    Here's what console has to say:

    @ Wed Feb 18 09:20:02 2015

    • Exception: DecompStream::GetFinishedFrame Corrupt frame detected in AA1377 frame 701 of sequence error codec CMError_Codec

    MPEG2IBP:Codec Decode Error -5

    Decode Stream failed.

    ------ Channel: input buffer ------

    Channel V_Dec_vc4077_ss64: ExecuteStream failed on Codec

    CChannel: error: CMError_Codec, function ExecuteStream, line 398, internal codec error string: MPEG2IBPCODEC_ERROR_IN_HUFFMAN_DECODE

    IBPCodec error: CMError_Codec

    Exception caught in APlayer::Play - Exception: DecompStream::GetFinishedFrame Corrupt frame detected in AA1378 frame 397 of sequence error codec CMError_Codec

    Exception:

    @ Wed Feb 18 09:21:05 2015

    • Exception: DecompStream::GetFinishedFrame Corrupt frame detected in AA1378 frame 397 of sequence error codec CMError_Codec

    MPEG2IBP:Codec Decode Error -5

    MPEG2IBP: error -5 at /Volumes/Data/Snapshots/relengsnow4_1414961757/xplat/Codecs/CMWrappers/MPEG2IBP/CMAvidMPEG2IBPCodec.cpp, line 379

    Decode frame failed.

    CChannel: error: CMError_Codec, function Execute, line 348, internal codec error string: MPEG2IBPCODEC_SUCCESSFUL

    IBPCodec error: CMError_Codec

    Exception caught in APlayer::Play - Exception: GetFinishedFrame Decompression Error in clip AA1378 error code CMError_Codec

    PlayerHostThread::CheckForExceptions: Exception: GetFinishedFrame Decompression Error in clip AA1378 error code CMError_Codec

    MPEG2IBP:Codec Decode Error -5

    Decode Stream failed.

    ------ Channel: input buffer ------

    Channel V_Dec_vc4077_ss64: ExecuteStream failed on Codec

    CChannel: error: CMError_Codec, function ExecuteStream, line 398, internal codec error string: MPEG2IBPCODEC_ERROR_IN_HUFFMAN_DECODE

    IBPCodec error: CMError_Codec

    Exception caught in APlayer::Play - Exception: DecompStream::GetFinishedFrame Corrupt frame detected in AA1379 frame 576 of sequence error codec CMError_Codec

    Exception:

    @ Wed Feb 18 09:22:50 2015

     

    • Exception: DecompStream::GetFinishedFrame Corrupt frame detected in AA1379 frame 576 of sequence error codec CMError_Codec

    THIS IS SUPER OUT OF DATE. WILL UPDATE IF I EVER REMEMBER System: AMC 8 (probably most recent version, subscriber) - Mac OSX Yosemite (10.10.3), 2.5 GHz... [view my complete system specs]
  • Wed, Feb 18 2015 6:05 PM In reply to

    • Isaac T.
    • Top 150 Contributor
    • Joined on Mon, Jan 9 2006
    • New York / Knoxville, TN
    • Posts 760
    • Points 8,995

    Re: Workaround for "Exception: DecompStream::GetFinishedFrame Corrupt frame detected"?

    AnthonyAmmo:

    The error still comes up after consolidating the footage. Same with transcoding. I've gone back and checked the original file on the shuttle drive from before transferring to our edit drive, but it's still happening there. I've also tried these things in my MC8 with the same results.

    Camera shut down incorrectly? Have you tried consolidating a portion of the clip? Similar case with details here:

    http://community.avid.com/forums/p/126674/725540.aspx#725540

    Mid-2010 Mac Pro • 2018 MacBook Pro [view my complete system specs]
  • Wed, Feb 18 2015 7:12 PM In reply to

    Re: Workaround for "Exception: DecompStream::GetFinishedFrame Corrupt frame detected"?

    Thank you for the reply.

     

    I cannot consolidate a portion of the clip. I get an error message, and then MC crashes.

    THIS IS SUPER OUT OF DATE. WILL UPDATE IF I EVER REMEMBER System: AMC 8 (probably most recent version, subscriber) - Mac OSX Yosemite (10.10.3), 2.5 GHz... [view my complete system specs]
  • Wed, Feb 18 2015 8:08 PM In reply to

    • Isaac T.
    • Top 150 Contributor
    • Joined on Mon, Jan 9 2006
    • New York / Knoxville, TN
    • Posts 760
    • Points 8,995

    Re: Workaround for "Exception: DecompStream::GetFinishedFrame Corrupt frame detected"?

    Have you tried this?

    https://forums.creativecow.net/thread/45/896237#896240

    Here's an excerpt:

    Download Canon's XF Utility from their website. Have it on any computer doing the AMA links as well as the Canon XF AMA plug in. For some reason this resolves a lot of the linking issues.

    It's from Shane Ross' boss, so you know it's worth a shot. 

    Last resort: grab AeroQuartet's Treasured app, open the troublesome MXF's in it. See how reparable they are.

    http://aeroquartet.com/movierepair/repair

    Otherwise, it doesn't look so good:

    http://community.avid.com/forums/p/79453/447912.aspx#447912

    http://community.avid.com/forums/t/20340.aspx

    Mid-2010 Mac Pro • 2018 MacBook Pro [view my complete system specs]
  • Thu, Feb 19 2015 9:04 PM In reply to

    Re: Workaround for "Exception: DecompStream::GetFinishedFrame Corrupt frame detected"?

    Awesome. Thanks a lot. I had downloaded the plug-in--didn't realize there was a full utility. Will try that when I come in tomorrow.

     

    I appreciate it!

    THIS IS SUPER OUT OF DATE. WILL UPDATE IF I EVER REMEMBER System: AMC 8 (probably most recent version, subscriber) - Mac OSX Yosemite (10.10.3), 2.5 GHz... [view my complete system specs]
  • Fri, Feb 20 2015 5:56 PM In reply to

    Re: Workaround for "Exception: DecompStream::GetFinishedFrame Corrupt frame detected"?

    I had to add an extra step, but it looks like the XF Utility was able to help!

     

    I had tried opening the MXFs in Premiere's Media Browser, but it would not read the full folder (it would cut off at 5:16 instead of merging all of the MXFs within a particular folder to create the full clip).

     

    So I tried the XF Utility and using it I was able to merge the MXFs within a folder to create (for example) a 10+ minute MXF. This MXF had the same "Exception: DeompStream..." error message coming up when I tried to AMA link it in Avid, but I was able to bring it into Premiere without any problems. I then export ProRes files from Premiere, which I bring into Avid.

     

    Thank you so much for drawing my attention to the external utility!

    THIS IS SUPER OUT OF DATE. WILL UPDATE IF I EVER REMEMBER System: AMC 8 (probably most recent version, subscriber) - Mac OSX Yosemite (10.10.3), 2.5 GHz... [view my complete system specs]
Page 1 of 1 (6 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller