Latest post Fri, Feb 2 2024 12:39 AM by ManChicken. 7 replies.
Page 1 of 1 (8 items)
Sort Posts: Previous Next
  • Thu, Feb 1 2024 8:35 AM

    • ManChicken
    • Top 500 Contributor
    • Joined on Mon, Feb 4 2008
    • Denver, CO
    • Posts 272
    • Points 3,540

    Audio scrub freezing playback on Lenovo P620 and DeckLink

    I have had MC running on an old HP z820 for a long time and recently just upgraded it onto a Lenovo P620 (AMD Threadripper Pro) re-using the Blackmagic DeckLink Studio 4K I had in the HP for video I/O. Also running Windows 11 now instead of 10.

    However our editor is having a massive problem which I've finally now figured out is due to (well, being triggered by) Audio Scrub being turned on. Without it turned on, I can scrub around the timeline crazily all day long, play sequences in a loop for hours at a time (yes I let one run playing continuously for about 6 hours the other day) and everything runs fine. However, if I turn on Audio Scrub, scrub around the timeline (which also works just fine) but then go to hit Play, the playback will spit out a few frames and then instantly freeze. Sometimes for a couple seconds, sometimes longer to the point that Windows goes to the spinning cursor and greys out the screen with MC not responding. Sometimes you can bang on Play a couple of times to free it up quicker, but usually you just get stuck for some random amount of time for it to free up its self. Scrub around again, it's all fine... but then hit play, and NOPE.

    Turn off audio scrub, and it goes back to behaving just fine.

    Here is a video showing the behavior:

    https://clients.idolum.com/get/e5b27144ad84

    You can't hear any audio as I can't easily capture it, but you can see from the meters that it's working as expected when appropriate (playing, scrubbing when turned on..)

    I'm currently running an older Desktop Video driver 12.5.1 that I downgraded to while trying to debug this, which is the same version I was running successfully on the z820 prior to taking it offline. But it happens with 12.7.1 which I originally installed when I configured the P620.

    Windows 11 Pro, 22H2 at the moment. I have an old RTX 2060 in it which again is the same card from the HP that working fine.

    Anyone have any ideas? We can work all day long with Audio Scrub turned off, but it's completely unusable with it turned on after the system has been running for a little bit (if I reboot, it will behave its self for a time -- sometimes -- but then start with the freezing behavior at some point.)

    Running MC 2023.12

  • Thu, Feb 1 2024 9:35 AM In reply to

    • Bruno M
    • Top 100 Contributor
    • Joined on Thu, Feb 11 2010
    • London, UK
    • Posts 1,054
    • Points 13,385

    Re: Audio scrub freezing playback on Lenovo P620 and DeckLink

    Were you running 2023.12 on the HP 820?

    We've been testing out the newer versions of MC at the fIlm school I lecture at.

    For years we had MC 2018 working perfectly well on our Intel iMacs, but upgrading to the M2 Mac Mini forced us to install later versions of the software.

    We found 2023.12 was plagued by annoying bugs. Although we didn't test your particular problem, the general consensus was that whatever new features the latest version had, it wasn't going to make up for the constant interruptions caused by these bugs.

    We've now settled for the 2022 version, which still has some bugs, but is the best compromise.

    We don't have these connected to Blackmagic hardware, which has it's own problems with M series Macs, but I haven't heard of any problems with Win 10/11.

    I run PC based systems at home and have 2023.12 on a HP Zbook G5 (Win 11) with Blackmagic hardware. I'll try out the audio scrubbing and get back to you.

     

    HP Z800, HP G9 Fury, SonnetFusion RAID, Mojo DX, Decklink 4K, Ultrastudio 3G, Symphony 2018 & 2022, Boland BVB25 OLED, JVC DTV1910 HD CRT, Eizo ColorEdge... [view my complete system specs]
  • Thu, Feb 1 2024 1:46 PM In reply to

    • Bruno M
    • Top 100 Contributor
    • Joined on Thu, Feb 11 2010
    • London, UK
    • Posts 1,054
    • Points 13,385

    Re: Audio scrub freezing playback on Lenovo P620 and DeckLink

    As promised, I've just tried this out on my setup and there's no problem playing after scrubbing, This is with both digital audio scrubbing on or off.

    Here's the specs of my setup...

    HP Zbook G5 - 16GB RAM, Win11 Pro v. 22H2

    Blackmagic Desktop Video v 12.7

    Avid MC v 2023.8.1 (not 2023.12 as I first mentioned)

    Blackmagic Ultrastudio 4K (the earlier version with TB2 and an Apple TB2-TB3 converter)

     

    Could this be a new bug introduced in 2023.12??

    HP Z800, HP G9 Fury, SonnetFusion RAID, Mojo DX, Decklink 4K, Ultrastudio 3G, Symphony 2018 & 2022, Boland BVB25 OLED, JVC DTV1910 HD CRT, Eizo ColorEdge... [view my complete system specs]
  • Thu, Feb 1 2024 3:27 PM In reply to

    • kkordisch
    • Not Ranked
    • Joined on Mon, Dec 5 2011
    • Posts 171
    • Points 2,150

    Re: Audio scrub freezing playback on Lenovo P620 and DeckLink

    The audio scrub freezing happens on mac apple silicon and intel as well.

  • Thu, Feb 1 2024 5:04 PM In reply to

    • ManChicken
    • Top 500 Contributor
    • Joined on Mon, Feb 4 2008
    • Denver, CO
    • Posts 272
    • Points 3,540

    Re: Audio scrub freezing playback on Lenovo P620 and DeckLink

    Bruno M:
    Were you running 2023.12 on the HP 820?

    No, I believe it was 2023.3 if I remember right. I guess I can try downgrading later today and see if it makes any difference. This problem seems hardware related, but in a very software-related way Big Smile

  • Thu, Feb 1 2024 9:13 PM In reply to

    • AntCaladine
    • Top 500 Contributor
    • Joined on Tue, Sep 11 2007
    • Stourbridge, UK
    • Posts 458
    • Points 5,825

    Re: Audio scrub freezing playback on Lenovo P620 and DeckLink

    There is a confirmed bug with 2023.12

    MCCET-5463 Enabling Digital Audio Scrub on a system with BMD I/O can cause playback issues and trigger hangs.

    Several people have been in contact with support over it. I've not had chance to revert to 23.8.2 to test that yet. But hopefully they fix it soon.

    2x HP Z8 G4, 96GB ram, Win11 Pro 64bit, Nvidia Quadro P4000 8GB AMC 2023.12 1x HP Z820 16GB ram, Win11 Pro 64bit, Nvidia Quadro 4000 AMC 2023.8.2 1x... [view my complete system specs]
  • Thu, Feb 1 2024 9:21 PM In reply to

    • AntCaladine
    • Top 500 Contributor
    • Joined on Tue, Sep 11 2007
    • Stourbridge, UK
    • Posts 458
    • Points 5,825

    Re: Audio scrub freezing playback on Lenovo P620 and DeckLink

    Also if you disable the blackmagic card in avid, digital scrub will work. But..... That depends if you have an audio card in your suite that connects to your speakers, and you can cope without your external monitor for the time being.

    2x HP Z8 G4, 96GB ram, Win11 Pro 64bit, Nvidia Quadro P4000 8GB AMC 2023.12 1x HP Z820 16GB ram, Win11 Pro 64bit, Nvidia Quadro 4000 AMC 2023.8.2 1x... [view my complete system specs]
  • Fri, Feb 2 2024 12:39 AM In reply to

    • ManChicken
    • Top 500 Contributor
    • Joined on Mon, Feb 4 2008
    • Denver, CO
    • Posts 272
    • Points 3,540

    Re: Audio scrub freezing playback on Lenovo P620 and DeckLink

    AntCaladine:
    There is a confirmed bug with 2023.12

    Finally was able to get in the room and downgraded to 2023.8.1 (I already had it sitting in my downloads folder from awhile back) -- and all is right in the scrubbing world again.

    Thanks all!

    (I'm subsequently going to grab and install 2023.8.2 as it fixed a crashing bug doing a lift or extract with audio scrub on..)

Page 1 of 1 (8 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller