Latest post Tue, Sep 5 2023 6:11 PM by Jason Sedmak. 6 replies.
Page 1 of 1 (7 items)
Sort Posts: Previous Next
  • Sun, Sep 3 2023 2:04 PM

    • jef
    • Top 25 Contributor
    • Joined on Sun, Feb 26 2006
    • Maryland
    • Posts 4,181
    • Points 50,460

    UHD source in HD Interlace sequence and Framflex artifacts

    MC 2023.3.1  OSx Big Sur

    I have encountered a major image quality problem.

    I have a series which must deliver 1080 59.94i.  Much of it is shot in UHD, which by definition will be progressive.

    When the UHD  material is placed in the sequence and the Framflex setting is at it’s default scale of 100, there are severe artifacts that point to incorrect scaling of Progressive material in an Interlace sequence.

    If Frameflex is set to scale of 50 (basically pixel to pixel - no scaling) then the image looks good.  No artifacts.  But as the scaling moves towards 100, the image quality begins to deteriorate.

    If I switch the sequence from 59.94i to 29.97p this problem goes away.  Whether scaled to 100 or 50 or dynamically adjusting.

    There are workarounds which are time consuming and should NOT be necessary.

    EDITED: Changed conversion of P to I to scalling of P in I.

    Avid DS 11.0.2 R.I.P | MC "Well, it depends ..." 2023.3.1 iMac w Big Sur and 2018.12.7 on Windows 10 Boot Camp [view my complete system specs]

    _____________________________________________

    Jef Huey

    Senior Editor

  • Sun, Sep 3 2023 5:07 PM In reply to

    Re: UHD source in HD Interlace sequence and Framflex artifacts

    I think this is an old issue, where the scaling is being done to the entire frame, rather than to the individual fields. Heard that one before some years ago. Forgot what the workaround was.

    Media Composer Symphony | PT Ultimate | Win10 HPZ | OSX MBP | ISIS5000 [view my complete system specs]
  • Sun, Sep 3 2023 5:23 PM In reply to

    • jef
    • Top 25 Contributor
    • Joined on Sun, Feb 26 2006
    • Maryland
    • Posts 4,181
    • Points 50,460

    Re: UHD source in HD Interlace sequence and Framflex artifacts

    Well the workaround I am suggesting to the client is mixdown the UHD / FrameFlexed shots after switching the sequence to Prog.  This creates HD shots.  Then switch back to Interlace for output. 

    This works but should not have to be done. I am really surprised that this still exists since FramFlex and UHD have been around so long.

     

    Avid DS 11.0.2 R.I.P | MC "Well, it depends ..." 2023.3.1 iMac w Big Sur and 2018.12.7 on Windows 10 Boot Camp [view my complete system specs]

    _____________________________________________

    Jef Huey

    Senior Editor

  • Mon, Sep 4 2023 5:49 AM In reply to

    Re: UHD source in HD Interlace sequence and Framflex artifacts

    • ➤  Bug Number: MCCET-3702. Image Quality issues when adding UHD progressive clips to an HD interlace sequence:

      The process Media Composer uses to mix and match video formats in a sequence is to transform the source clip's frame rate and frame layout to meet the project specifications; the motion adapters are added first, then spatial adapters are applied in order to provide expected playback dimensions.

      For example, if you have a UHD 50p clip that you want to add to a 1080i Timeline, the UHD clip first gets split into 2 separate fields (UHD format), then each field gets independently resized to 1920x540 in HD. The export process puts those resized fields back together into a progressive HD frame but does not maintain the clarity of the original progressive frame. 

      1. Workaround: If you first transcode the UHD progressive clip to HD progressive and then add the HD clip to the interlace sequence, it forces the resize operation from UHD to HD to be done before the split gets into interlace mode. 

    Media Composer Symphony | PT Ultimate | Win10 HPZ | OSX MBP | ISIS5000 [view my complete system specs]
  • Mon, Sep 4 2023 12:10 PM In reply to

    • jef
    • Top 25 Contributor
    • Joined on Sun, Feb 26 2006
    • Maryland
    • Posts 4,181
    • Points 50,460

    Re: UHD source in HD Interlace sequence and Framflex artifacts

    Job ter Burg:

    • ➤  Bug Number: MCCET-3702. Image Quality issues when adding UHD progressive clips to an HD interlace sequence:

    Thanks for finding that Job. When was that bug reported? I do remember it now. I also remember reading the suggested work around and laughing as it basically said "You can not take advantage of UHD resolution in an interlace project".  Well, I am not laughing now.

    I realize I have not run into the issue before as the majority of projects that I have done in which there was UHD source for a HD finish were 23.97p.  Any conversion to interlace occured after the creation of a HD master.  That is not practical for this series as there is a lot of native interlace material.  Deinterlacing those sources to progressive just to turn around and add interlacing back is NOT a good workflow.

    I have opened a support case.

    Jef

    Avid DS 11.0.2 R.I.P | MC "Well, it depends ..." 2023.3.1 iMac w Big Sur and 2018.12.7 on Windows 10 Boot Camp [view my complete system specs]

    _____________________________________________

    Jef Huey

    Senior Editor

  • Mon, Sep 4 2023 5:23 PM In reply to

    • jef
    • Top 25 Contributor
    • Joined on Sun, Feb 26 2006
    • Maryland
    • Posts 4,181
    • Points 50,460

    Re: UHD source in HD Interlace sequence and Framflex artifacts

    A bit of research shows that the bug MCCET-3702 shows up in the Limitations section of the release notes for MC 2021.6 of June 17, 2021.

    Over 2 years ago.

    Jef

    Avid DS 11.0.2 R.I.P | MC "Well, it depends ..." 2023.3.1 iMac w Big Sur and 2018.12.7 on Windows 10 Boot Camp [view my complete system specs]

    _____________________________________________

    Jef Huey

    Senior Editor

  • Tue, Sep 5 2023 6:11 PM In reply to

    Re: UHD source in HD Interlace sequence and Framflex artifacts

    Jef:

    Any chance you can share a tiny sample? I don't typically master OUT of Avid using interlaced, but if I grab a UHD 23.98p clip and drop it into a test 1080i sequence, I don't see any clear artifacting on my end.

    I've tried with Sony, Cannon, and RED UHD clips and above.

    j

    Custom, i9-13900K, AMD 6900XT, 64 GB RAM, m.2 SSD, 10gige to TB, BM SDI 4k (BMDTV 12.8), Mac OS 14.4. MC 2024.2 [email protected] [view my complete system specs]
Page 1 of 1 (7 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller