Latest post Wed, Feb 16 2022 9:32 PM by Jason Sedmak. 12 replies.
Page 1 of 1 (13 items)
Sort Posts: Previous Next
  • Wed, Feb 9 2022 6:22 PM

    • Roland
    • Not Ranked
    • Joined on Sat, Oct 15 2011
    • Germany
    • Posts 7
    • Points 85

    UME linked Clips are Offline

    Hi Avid-friends,

    i have a really big problem, maybe someone has a solution: I am working on Mac OS Catalina since some weeks, editing with Media Composer 2021.3.

    So, because of Catalina i am not able to import .mov-clips, so i have to link them via UME. I use this very often for graphics and animations. But this is really not working smooth already: updated clips are not refreshed in MC, it uses a lot of time, until MC recognizes the new content. But the biggest progblem: regularly a lot of these UME-linked clips on my timeline are  offline. And there is no way, to relink them.

    At the moment i have link them as new UME-clips into the bin, and then reedit into timeline. Thats a desaster on mornings, when i have to deliver my work, and a dozen of clips are offline Surprise

    i tried to open the source browser, opened the source directory, so that MC is forced to read all metadata once again. With offline clips from my cams this workaround works, but not for mov-files from f.e. After Effects.

    Please, does anyone has an idea, what to do?

    Thank you very much,

    Roland.

     

     

    Filed under: , ,
  • Wed, Feb 9 2022 10:48 PM In reply to

    Re: UME linked Clips are Offline

    Hi Roland, Sorry to hear that's been happening... sounds like a nightmare. 

    Firstly I of course woudn't recommend editing with linked media on the timeline. I would always work with transcoded media. 

    Anyway, you could try to rebuild the AMA management database. Note ALL your linked clips will go offline the moment you do this. You should be able to simply link again your raw footage to a bin with your offline linked clips and the clips will go online again. If the timecode matches there shouldn't be any re-cutting involved. 

    Here's how to rebuild the AMA management database: https://avid.secure.force.com/pkb/articles/en_US/how_to/rebuild-AMA-Management-folder

    In future instead of crosscutting you should try to "relink" your offline master clips. 

    Let me know if that works

    Editing Movie Magic.

    My Equipment & System Specs

    Media Composer Ultimate 2022.7 | Pro Tools Studio 2022.6 | Sibelius Artist 22022.5

  • Thu, Feb 10 2022 8:02 AM In reply to

    • Roland
    • Not Ranked
    • Joined on Sat, Oct 15 2011
    • Germany
    • Posts 7
    • Points 85

    Re: UME linked Clips are Offline

    Hi Philip,

    thank you very much for your reply. unfortunately it does not work. i renamed the ama management directory and then restared MC, but all offline clips are still offline. strange is, that all other ama clips, that were online before, are still online. i thought, that these clips should be offline too, until i open the source directory and the data is build new in the ama management folder.

    And you are right: i relink all the offline clips in my timeline. if i would reedit them via in/out, i would freak out :-) but this workflow always results in doubled clips in my bin, very confusing.

    meanwhile i updated to MC 2021.12 with the legacy tools for mac - nothing changes.

    working with transcoded media is and was always my favorite solution, but these clips are not able to be reimported. so i am not able to do changes in the graphics clips, without importing the clips as new files and redediting them or relinking to timeline - no advantage.

    The solution will be now: that i dont use mov-files anymore. but mxf-exporting from adobe brings new problems. and alpha clips are not possible as mxf from Adobe Media Encoder, or does anyone has a workflow for this transparent alpha clips?

    Thank you for yout idea,

    Roland.

     

  • Thu, Feb 10 2022 1:49 PM In reply to

    • Roland
    • Not Ranked
    • Joined on Sat, Oct 15 2011
    • Germany
    • Posts 7
    • Points 85

    Re: UME linked Clips are Offline

    After updating to MC 2021.12 importing psd or png results in total crashes, and i have to restart MC.

    At the moment, i really don´t know what to do.

     

  • Thu, Feb 10 2022 11:07 PM In reply to

    Re: UME linked Clips are Offline

    Roland:

    The solution will be now: that i dont use mov-files anymore. but mxf-exporting from adobe brings new problems. and alpha clips are not possible as mxf from Adobe Media Encoder, or does anyone has a workflow for this transparent alpha clips?

    Try exporting .AVI if you want to import graphics with alpha channel

    You could also submit a support case: https://www.avid.com/learn-and-support/contact-support

    Editing Movie Magic.

    My Equipment & System Specs

    Media Composer Ultimate 2022.7 | Pro Tools Studio 2022.6 | Sibelius Artist 22022.5

  • Fri, Feb 11 2022 8:13 AM In reply to

    • MikeyB
    • Top 200 Contributor
    • Joined on Thu, Oct 13 2005
    • Edlesborough, UK
    • Posts 607
    • Points 7,590
    • Avid Certified Instructors - Video
      Moderator: Avid Certified Instructors - Video

    Re: UME linked Clips are Offline

    I'm a bit confused by this thread.

    Why use UME at all? If you're on a Mojave-based Mac and have the Legacy Components package installed, the 'old' import routines should still work.

    Even if you choose to link graphics, the QuickTime plugin should be available? 

    2021 MacBook Pro 16" (M1 Max 32GB), 2019 iMac 27" (8-core i9, 40GB) [view my complete system specs]
  • Fri, Feb 11 2022 9:04 AM In reply to

    Re: UME linked Clips are Offline

    MikeyB:
    If you're on a Mojave-based Mac

    He's on a Catalina system:

    Roland:
    I am working on Mac OS Catalina

    So all the 32-bit Quicktime stuff doesn't work any more, and getting it all linked back up is confusing and complicated.

    To Roland, there is a lot of information in the v2020.4 ReadMe that covers the switch to UME linking in MacOS Catalina and later (I know you're running a later version, but the information still applies). It might help to have a look at the sections titled 'MacOS Catalina support' and 'Avid Universal Media Engine (UME)':

    https://resources.avid.com/SupportFiles/attach/WhatsNew_MediaComposer_v20.4.pdf

    Media Composer 2022.7 w/Symphony/SS/PF options, HP Z-Book G6 17", i7-9850H 2.60GHz, 32gb RAM, NVIDIA Quadro RTX 3000, Blackmagic UltraStudio Mini... [view my complete system specs]

    "There is hardly anything in the world that some man cannot make a little worse and sell a little cheaper, and the people who only consider the price are this man's lawful prey."  - John Ruskin (1819-1900)

     

    Carl Amoscato | Freelance Film & Video Editor | London, UK

  • Fri, Feb 11 2022 12:51 PM In reply to

    • MikeyB
    • Top 200 Contributor
    • Joined on Thu, Oct 13 2005
    • Edlesborough, UK
    • Posts 607
    • Points 7,590
    • Avid Certified Instructors - Video
      Moderator: Avid Certified Instructors - Video

    Re: UME linked Clips are Offline

    Oops, sorry!

    2021 MacBook Pro 16" (M1 Max 32GB), 2019 iMac 27" (8-core i9, 40GB) [view my complete system specs]
  • Wed, Feb 16 2022 4:43 PM In reply to

    Re: UME linked Clips are Offline

    Philip Kapadia:
    Firstly I of course woudn't recommend editing with linked media on the timeline. I would always work with transcoded media. 

    With all due respect, PK, what the heck? I realize that transcoding has been the defacto MO since Avid's inception, and that many many people don't even think about using AVID until they've had their clips transcoded, but the very premise of AMA-linking is the ability to work with clips linked all throughout the process.

    I work (almost) 100% using linked material, and that's coming from just about every camera file imaginable, every frame-rate there is, and just about anything as high as 6k and using with hours and hours of material. My shop's typical turn-around time and sheer volume of high-raster footage frequently doesn't allow the extra day of down-time to trancode. Now, if I have cpu taxing, high-compression 4k+ footage, then, yes, I will sometimes make proxies (whether that's AVID transcoding or using Resolve), but I do also have a pretty robust machine.

    As far as re-linking AMA material... this has been discussed endlessly, but yes, AVID STILL is less than ideal when it comes to this... why is the "Relink to File(s)" menu item STILL non-functional again? 

    I'm just saying that rather than perpuating a narrow-use workflow, we should be encouraging people to extend their boundaries and understanding of what the software can do, and how to do it.

    To the point; OP, it appears you tried to relink via source-browser, but perhaps you didn't see it through totally:

    1) Select ANY bin, go into Source Browser, and navigate ALL THE WAY down to the ACTUAL files that need re-linking until you see the ACTUAL files. Watch the "Plug-in" column auto-populate the link type, and wait for all of them to be re-indexed (whether by scrolling through, or waiting for the green activity circle on the bottum left to finish). Do this for all files you need to relink. This will relink your master clips, and if those master clips are in sequences, those ciips, too.

    2) If you get a "Plug-in" message that says "Can't be Linked" then you are either missing codecs, or it's a file that AVID doesn't support.

    3) If these files were linked via an older version with a different codec system, then sometimes they don't relink by this method, and then, yes, the best next method is to link them fresh into a bin and delete the old (unlinked) master clips.

    4) Once you have the master clips online in bins, if you still have sequences that are unlinked, use the "Relink..." tool to relink everything to your sequences, using the "Selected Items in ALL Open Bins" feature, then mess around with the two "Relink by:" attributes that can help AVID discern HOW to match metadata attributes.

    I do this ALL the time, and believe me it works and DOES NOT require manually re-editing ANYTHING into sequences. The ONLY time it does not work is when there are mis-matching metadata attributes that affect HOW I'm trying to relink (like if I'm using "Name" when the names are different and I can't filter out two-way extensions, such as .sub or .new to clips with spanned or unique filenames (like Resolve renders), or if whole clips are being re-linked and for whatever reason the full clip durations no longer match).

    Onward and upward,

    J

    Custom, i9-9900K, AMD Radeon VII 64 GB RAM, m.2 SSD, 8x 10GigE to Terrablock, BM SDI 4k, currently running Mac OS 12.2.1. MC Ultimate 2021.12-2 [view my complete system specs]
  • Wed, Feb 16 2022 5:36 PM In reply to

    Re: UME linked Clips are Offline

    Jason Sedmak:

    With all due respect, PK, what the heck? 

    Here we go!

    Jason Sedmak:

    many many people don't even think about using AVID until they've had their clips transcoded

    I'm one of them. 

    Jason Sedmak:

    I do also have a pretty robust machine.

    I'm sure you do... but not everyone does. Forget trying to edit linked 4K DCI long-gop on my system which is why I wouldn't ever dream of editing master clips linked straight to camera rushes, especially on some of the long-form projects I do. In my initial message, I should have added "most of the time... I wouldn't recommend editing with linked media". 

    Jason Sedmak:

    I'm just saying that rather than perpuating a narrow-use workflow, we should be encouraging people to extend their boundaries and understanding of what the software can do, and how to do it.

    An admirable crusade you're leading. That's all well and good if you have the raw system power, but if you don't (most people don't), a direct online workflow, or a workflow where you work with linked only will quite simply fall apart. The whole point of transcoding is to work with offline clips that your CPU, hard drive(s), RAM, etc can keep up with when in the craft edit. God forbid I edit (offline, then transcode to online codec) a 30 camera green screen music video, linked only, with long-gop footage. 

    The workflow you choose depends so much on your project, system, turn around time. So many factors. You've found a workflow that works for you; good for you! In the majority of cases with standard offline computers, that workflow won't work.

    Jason Sedmak:

    I do this ALL the time, and believe me it works and DOES NOT require manually re-editing ANYTHING into sequences. The ONLY time it does not work is when there are mis-matching metadata attributes that affect HOW I'm trying to relink 

     

    agree. 

     

    Editing Movie Magic.

    My Equipment & System Specs

    Media Composer Ultimate 2022.7 | Pro Tools Studio 2022.6 | Sibelius Artist 22022.5

  • Wed, Feb 16 2022 5:48 PM In reply to

    Re: UME linked Clips are Offline

    Not gonna start a pi$$ing match, so let me just say, touche!

    But, 30-camera green screen!!!! Double ouch! I realize you're being flippant, but can you imagine trying to pay attention to that camera-split?

    Cheers,

    J

     

    Custom, i9-9900K, AMD Radeon VII 64 GB RAM, m.2 SSD, 8x 10GigE to Terrablock, BM SDI 4k, currently running Mac OS 12.2.1. MC Ultimate 2021.12-2 [view my complete system specs]
  • Wed, Feb 16 2022 8:07 PM In reply to

    Re: UME linked Clips are Offline

    Jason Sedmak:

    Not gonna start a pi$ing match, so let me just say, touche!

    But, 30-camera green screen!!!! Double ouch! I realize you're being flippant, but can you imagine trying to pay attention to that camera-split?

    Cheers,

    J

     

    When I edit a music video, I group all of my performance takes into one big ol' multicamera group. If they shot 30 performance takes, my multicamera group would have 30 cameras in it. I sync it up at the beginning with the music and then I never have to worry about sync again. If I want to replace or change a shot I just select it from the camera bank, instead of marking in and out from bins - which would be a pain in the ass to sync every time. It's just how i've always done it and to be honest I don't really know how other editors do it. 

     

    I believe avid only plays back the shots that are actually being viewed in the source monitor as individual tiles, so although I could have a 30 shot multicamera group, only the 9 will be playing back using my resources, so that's 9 streams of DNxHD LB. I can't playback 9 streams of long gop simultaneously on my system... it's just not possible. 

     

    Once I finish my offline edit with my stupidly large m-cam group, I then re-link back to my UME/AMA linked media, then transcode the linked sequence into DNxHR HQx for online and colour correct. for 4K and 6K music videos I take this a step further and "proxy" my transcodes and timeline down to HD, I then turn the proxy feature off in online and work in the native resolution. 

    Editing Movie Magic.

    My Equipment & System Specs

    Media Composer Ultimate 2022.7 | Pro Tools Studio 2022.6 | Sibelius Artist 22022.5

  • Wed, Feb 16 2022 9:32 PM In reply to

    Re: UME linked Clips are Offline

    Okay! You win! I def concede that that right there is a terrific case of HAVING to work with transcodes/proxies!

    Holy h-e-double-hockeysticks!!!

    Big Smile

     

    Custom, i9-9900K, AMD Radeon VII 64 GB RAM, m.2 SSD, 8x 10GigE to Terrablock, BM SDI 4k, currently running Mac OS 12.2.1. MC Ultimate 2021.12-2 [view my complete system specs]
Page 1 of 1 (13 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller