Latest post Thu, Apr 15 2021 7:29 PM by Marianna. 1 replies.
Page 1 of 1 (2 items)
Sort Posts: Previous Next
  • Mon, Apr 12 2021 1:12 PM

    • RHenman
    • Not Ranked
    • Joined on Sun, Nov 15 2020
    • Posts 2
    • Points 30

    Avid Link Not Opening

    Ive just bought Media Composer Ultimate, and after dowloading the software asked to "activate using Avid Link"

    However when I go to open Avid Link, it doesnt do anything. It says it's downloaded on my computer (PC), but the application itself isnt opening. 

    So far ive tried reinstalling it, making sure all other Avid products were correctly uninstalled.

    Ive tried installing an older version of link, but to see that app not open either

    And Ive tried phoning Avid support, but when asked for my Activation ID the auto-service says it doesnt exist and I am `unable to continue the call (I payed for the product yesterday)

     

    Any ideas on how I can access Link?

  • Thu, Apr 15 2021 7:29 PM In reply to

    • Marianna
    • Top 10 Contributor
    • Joined on Thu, Oct 13 2005
    • Avid
    • Posts 11,551
    • Points 255,080
    • Avid Beta Moderators
      Avid Customer Advocate
      Avid Developer Moderator
      BlogAuthor
      SystemAdministrator

    Re: Avid Link Not Opening

    RHenman

    What computer are you on and are you on Win 10 enterprise or professional?

    Email me the system ID and your MyAvid email address.

    Marianna

    Director of CSM | Customer Advocate [view my complete system specs]
Page 1 of 1 (2 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller