Browse Site by Tags

Showing related tags and posts accross the entire site.
  • Newer O/S with old AVID MC

    Stupid question: Roughly speaking I guess it’s fair to say: the latest versions of Max O/S more or less support the latest AVID Versions. Sort of. Ish. But is it fair to say the newer versions of Mac O/S will support much older AVIDs? Quite a lot of other apps seem to continue working un hindered...
    Posted to Avid Media Composer - Mac (Forum) by anglegrinderUK on Tue, Oct 2 2018
Page 1 of 1 (1 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller