Browse Forum Posts by Tags

Showing related tags and posts for the Get Started Fast forum. See all tags in the site
  • Avid Customer Care needs improvement NOW

    There seems to be a growing pandemic of error 404 on the Avid and Avid community site. From the customer support page (linked from an avid email less than a week old), I tried to send my issue via multiple topic buttons and their subsequent form windows to no avail (see further below). I tried numerous... (read more)
    Posted to Get Started Fast (Forum) by jaynew16 on Tue, May 24 2016
  • Left stranded with no Media Composer

    Because of windows 10 I'm now left with a Media Composer that won't work. I was advised, at length, via emails how to sort this out (taking up many hours of my time) only to be told that I can no longer get the upgrades I need. Is this what happens with Avid - after four years your left with... (read more)
    Posted to Get Started Fast (Forum) by Jamesish on Fri, Oct 23 2015
  • Avid Won't Return Phone Calls

    Hey all, I had an Avid Standard Support plan that expired on July 14, 2015. The very next day, I called Avid to purchase another year of support so I could keep with the latest Media Composer updates. For some reason, my account would not let me do it online, so I had to call. My first time calling,... (read more)
    Posted to Get Started Fast (Forum) by JHensley on Sun, Sep 13 2015
  • MBOX MINI NOT CONNECTING.........HELP HELP HELP HELP!!

    Hello everyone, i am a new pro tools user, when i first bought my pro tools express i installed it and imediatelly it didnt work, the drivers were installed etc. I had to call avid and get them to help me as i didnt know what to do. What it was doing was, it wasnt recognizing my mbox, or it was saying... (read more)
    Posted to Get Started Fast (Forum) by espmaniac01 on Thu, Jan 9 2014
  • Dongle update

    I am afraid I am at the end of my extnsive store of patience with trying to update my dongle for MC 7.0.3. I have successfully gotten emails with the updater.avd file in them but it is always zero bytes and it will not show up when I use the dongle manager to try and upgrade the dongle. I have tried... (read more)
    Posted to Get Started Fast (Forum) by zanderfarns on Tue, Dec 31 2013
  • Marquee Tool Keeps Freezing

    Is there a number that I can call to actually speak with someone from customer service about Media Composer 6. I've had it for about a year now and the service codes I have are no longer good and won't let me get through to talk to someone. Thanks. (read more)
    Posted to Get Started Fast (Forum) by milo07 on Fri, Feb 22 2013
  • I bought my Pro-Tools and M-Box at Guitar Center

    I can't find any help on this site for my problems. I registered my products the registration window just disapeared, I cant see anywhere on my "master account" where my stuff is listed. So I'm sitting here with a brand new M-Box and some installation discs and I can't use either... (read more)
    Posted to Get Started Fast (Forum) by Dac Rambo on Sun, Feb 17 2013
Page 1 of 1 (7 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller