Latest post Mon, Apr 19 2021 7:07 PM by knejmann. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • Mon, Apr 19 2021 2:03 PM

    • Roland W
    • Not Ranked
    • Joined on Thu, Feb 19 2015
    • Posts 15
    • Points 205

    import markers with German umlaut

    I generated Avid markers from a transcript by "simonsays". works fine -  it generats a .txt file with the regular German umlauts like Ö Ä Ü etc. But when I import them in the markers window the Ä Ö Ü get transformed to crazy symbols. So instead "für" I get "f√º" which makes the markers a pain to read. I tried all variations of formating (UTF8, ANSI) but no success

    Filed under: , ,
  • Mon, Apr 19 2021 3:47 PM In reply to

    • jo56lu
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Luxembourg
    • Posts 52
    • Points 680

    Re: import markers with German umlaut

    I have the same problem, but the other way around.

    Exporting markers as .txt file changes umlauts (in my case not only German ä,ö,ü but also French é,è, etc) in non readable characters that have to be edited manually.

    I would be pleased to find a solution.

    HP Z840 2 x E5-2630V3 8 core, 32 GB RAM, Quadro K4200, AJA KONA LHe Plus w/KL-Box, LSI internal RAID, Win 7 Pro, Avid MC 8.10 w/Symph option [view my complete system specs]
  • Mon, Apr 19 2021 7:07 PM In reply to

    • knejmann
    • Top 500 Contributor
    • Joined on Fri, Nov 4 2005
    • Århus, Denmark
    • Posts 285
    • Points 3,215

    Re: import markers with German umlaut

    Here's Your Encoded FileNot near Media Composer but my old notes says that Markers (as .txt - not XML) must be encoded as codepage 10000 aka Mac Roman.

    So you need a text editor that will read the file correctly and then save or convert to Mac Roman.

    Google says that this will do the job:


    You can also convert using Python if you are familiar with that. From my notes there is an example that should the oposite of what you need :-) So the encoding should be macroman for the line with fout:


    import codecs

    with'd:\macroman.txt', 'r', encoding='macroman') as fin:

        file_content =

    with'd:\macroman_utf8.txt', 'w', encoding='utf-8') as fout:


    Edit: And of course there are online options. This is not pretty but seems to work Just select "Target CharSet Encoding: Macintosh". Click Convert and look for the link "Here's your encoded file"


    Media Composer 2020.12.6 - Windows 10 - Dell 8520 - Blackmagic Decklink Studio 4K - Interplay and NEXIS storage - Avid Artist Color. [view my complete system specs]

    Kåre Nejmann

    Danish Broadcasting Corporation - DR
    Aarhus, Denmark 

Page 1 of 1 (3 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller