Latest post Fri, Apr 12 2019 5:26 PM by ck123. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • Fri, Apr 12 2019 7:33 AM

    • ddowner
    • Not Ranked
    • Joined on Sat, Aug 1 2009
    • Burbank, CA
    • Posts 12
    • Points 150

    Purchased a month avid License, I need v8.9.4, can’t activate.

    I purchased a monthly media composer license but can’t seem to activate v8.9.4 with the license key I purchased. 

     

    Is there any way to use this version?

     

    specs: win 10, 1060 GTX, 32 GB ram, 1TB HDD. 

    Mac OSX 10.6.3 2x3.2GHz Quad Core Xeon Processor 6GB 800 MHz DDR2 RAM Avid Adrenaline 5.0.3/Symphony 5.0.3 [view my complete system specs]
  • Fri, Apr 12 2019 11:49 AM In reply to

    • Pixel Monkey
    • Top 75 Contributor
    • Joined on Thu, Oct 13 2005
    • Everywhere. Just like Avid ;)
    • Posts 1,240
    • Points 15,655
    • Moderator: Broadcast Newsroom
      Moderator: Media Composer Getting Started

    Re: Purchased a month avid License, I need v8.9.4, can’t activate.

    It should work. What is specifically happening when you try? Are there error messages? If so, what do they say?

    ACA Leader__Avid Pro Vid Moderator__Specs? Many. All qualified. But I still do stupid things. :) [view my complete system specs]

    Editors are superheroes, cutting life together in a world that cuts itself apart.

     

    Chris Bove' (Pixel Monkey)

    Twitter: Follow @heybove

    Blog for Craft Editors

    WWLD (What Would Larry Do?)
    WWND (What Would Norman Do?)

  • Fri, Apr 12 2019 5:26 PM In reply to

    • ck123
    • Not Ranked
    • Joined on Wed, Jul 17 2013
    • Posts 132
    • Points 1,665

    Re: Purchased a month avid License, I need v8.9.4, can’t activate.

    Which product specifically did you lease? Media Composer Ultimate is the only one that supports older 8.x versions. Also, begining in June new purchases/leases will only support back to 2018.9.

    • On May 30, 2019, Avid will begin selling perpetual software licenses and subscriptions of Media Composer that will only run v2018.9 or later.
    • In addition, when an existing subscription (a subscription started before May 30, 2019) is renewed, it will also only run v2018.9 or later.
    HP Z400, z220, and z420 workstations with 8GB of RAM and nVidia Quadro 2000 graphics cards. Windows 7 64-bit SP1. ISIS 5000 4.2. [view my complete system specs]
Page 1 of 1 (3 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller