Latest post Wed, Aug 6 2014 7:50 PM by Jasper Quispel. 8 replies.
Page 1 of 1 (9 items)
Sort Posts: Previous Next
  • Sat, Feb 23 2013 3:17 PM

    • Zbig_
    • Not Ranked
    • Joined on Sat, Feb 23 2013
    • Posts 4
    • Points 60

    Stereoscopic S3D project - left/right eye EDL not working

    Hi,

    I`m new to the forums, also english is not my native language so excuse me for any inaccuracies.

    It`s going to be a long post...

    I`m working on a stereoscopic project in 1080p/25, footage was recorded on RED Scarlet with a mirror rig -some shots were 4K, some 2K(slow motion).

    I use Avid Media Composer 6.5 on a Windows PC.

    I did a basic color matching in RedCine-X Pro of R3d files for each eye, and exported them with option Avid AAF & MXF(DNxHD 36 flavour/ debayer good). I put MXF files into Avid MediaFiles, imported AAF into project, merged the AAF files with ALE file, synced into s3d clips(I put my labels into column "group names", instead of using "populate s3d group names automatically"). There was no sound on set, but later I realized that some of the r3d clips had audio tracks(empty) - during the s3d clips creation in AVID I used the option to not use the sound that was available in r3d files.

    Everything looked fine at this point. After rough edit(with effects like timewarps and 3dwarps) I wanted to export some footage to fellow matte painter - but HD export of graphic files or movies were not enough for him (movie was done on a bluescreen, so there is going to be a lot of keying, tracking and matte painting), and DNxHD 36 is not for finishing of course . He wanted original media files, but at the same time I wanted to be able to give him only the parts of the footage that he will need to use. We`ve got limited budget, so we try to use whatever we can.

    I thought If I export AAF (link to) it will point to the MXF media - and I wanted r3d files - so I hid the Avid MediaFiles folder from Avid by adding some letters to the name of this folder - and played with relink option inside AVID. After a few tweaks, such as choosing "ignore characters after last occurance"and adding "_", and some other options, AVID relinked to the original r3d files that were on a same disk(through AMA). I exported AAF with "aaf protocol" option(without it gave me an error). Some people write that AAF is not an option with AMA files, but It works with video...

    These are the results for AAF:

    AAF(for each eye) - tried to open through Pro Import in After Effects CS 6(doesn`t matter if I export right or left eyed AAF- in After it opens with both eyes in precomps - It gave us the best results so far, the sequence from Avid match very nicely with minor errors - but for each eye we need to create stereo rig, etc...)

    In  Davinci Resolve import of AAF gave me a lot of tracks with clips above each other or next to each other - sometimes the clips were blank, and the parts of avid sequence didn`t match with the ones in Davinci

    With EDL I tried with MXF files, as with r3d files(I dont remember if it was tested before the AMA trick, or after I once again relinked to the MXF files) - maybe it messed something up - but when I check column bins , and ALE file - they are the same(after the AMA trick and back again).

      So EDL - only gives me option for monoscopic - timecodes and source/tapenames match, and I can save it and open for example in RedCine-X Pro - without effects of course - but it works. When I try to use Left or Right - edl manager gives me "AX" in source file column, and timecodes are random. I tried using "get sequence"(which works for monoscopic), along with opening the bin with closed Avid(edl manager gives the message: "The file is not valid and cant be opened").

    I tried with sequences without effects, with effects, with only one track of video.

    Monoscopic EDL also is messed up after opening in Davinci, and in Speedgrade it doesn`t open at all(but as I said RedCine-X pro opens and connects edl to the r3d files, after pointing to the folder that contains original media files).

    EDL manager console gives me such errors(sometimes, but not always) :

    "unable to find Soundroll at composition timecode…"

    and sometimes: "unable to find Camroll at compositon timecode…"

    I tried to open the project on my mac (I copied media and project on my personal drive) - same problems.

    So basically what I want to achieve is 2D edl`s for each eye, so that I could export fullframe graphic sequences in 3rd party software. I read that edl export for s3d projects is flawed(timecode inaccuracies) but it`s not the problem here.

     

    Any help or hint will be much appreciated.

    Many Thanks!

    Zbig_

  • Thu, Feb 28 2013 8:37 PM In reply to

    • Mike Fay
    • Not Ranked
    • Joined on Thu, Oct 13 2005
    • Los Angeles
    • Posts 75
    • Points 890

    Re: Stereoscopic S3D project - left/right eye EDL not working

    Hi Zbig, 

     

    I'm seeing the same EDL problems on my end. Monoscopic will give the correct TC, but selecting Left or Right will give incorrect TC and "AX" instead of Tape / Source File name. I haven't done any of the AMA relinking you did, I'm just dealing with MXF files, so the problem does not appear to be related to your AMA hack (which is very cool, BTW). 

     

    Just an idea, but it could be that Davinci and Speedgrade are not liking the EDL because it's only referencing a single Eye. You could try editing the EDL in a text editing program to modify the Eye indication in the Source File name. So, if your current EDL is Monoscopic and listing a Source File with an "L" at the end, change that to an "R" and see if Resolve or Speedgrade can read it. 

     

    Good luck!

     

    Mike

    MacBook Pro 2.4 GHz Intel Core i5; 8 GB RAM; OS 10.8.3; Media Composer v6.5.2 [view my complete system specs]
  • Fri, Mar 1 2013 10:41 AM In reply to

    • Zbig_
    • Not Ranked
    • Joined on Sat, Feb 23 2013
    • Posts 4
    • Points 60

    Re: Stereoscopic S3D project - left/right eye EDL not working

    Hi Mike,

    Thanks for replying, I thought I was alone with this problem :)

    I think your idea is good, and logic, but I see a problem here. The RED Scarlet camera gives different names to the end of each clip so the file names will not be duplicated - I read it in RED scarlet user guide, also I investigated this case with fellow camera assistant. Also our cameras aren`t paired by timecode - so each eye have different timecodes. The cameras are only paired by reel and clip number(beggining of the clip name), and the time when they start to record.

    This is an example of a two clip that create stereo pairs in avid without problem with their (source) start timecode:

    Clip 1:

    A001_L001_020213_001  20:05:25:24

    A001_R001_0202F9_001  20:03:11:17

    Clip 15:

    A001_L015_0202IU_001    21:14:22:01

    A001_R015_02023C_001   21:12:07:18

     

    The last two letters/digits after the date (0202 - february second) are random. So only changing the "L" or "R" will probably not work - I would have to change the last two characters in each clip name, and timecodes are different so I would have to manually input timecode for right eye. So basically I would have to write the whole EDL. Maybe I`m mistaken(I would like to, really), and I`m overlooking something, but these are my sad conclusions...

    Maybe it is mandatory for clips to have the same timecode, or something else - but why then avid would have option to sync stereo clips by "first frame"? Maybe the problem lies in camera settings, something that should be set on "set"...maybe even on a hardware side (genlocks, timecode generators, etc... - if we had any... :)

    Maybe you Mike, or somebody else can enlighten me? :)

    Thanks!

    Zbig_

  • Fri, Nov 15 2013 4:57 PM In reply to

    Re: Stereoscopic S3D project - left/right eye EDL not working

    Hi,

    I edit a 3D film in MC7.02 (in 3D) and we will go to Resolve 10 for grading. 

    I look anz help in going from Avid MC 7 to Resolve. AAf give me that 40 video track and some clips every where..

    I see your messages of last march..  did you find any way to do this workflow possible?

    Thank you

    Merci

    Danke

    Grazie

    ...

    Fabrice A. 

    MC7.02 / Mac Pro 3.1 / OSX 10.8.5 / 16 go Ram / BM decklink HD extrem 2. / Quadro 4000 + Quadro K5000 / 16 To Raid Hard Drive [view my complete system specs]
  • Fri, Nov 15 2013 8:31 PM In reply to

    • Zbig_
    • Not Ranked
    • Joined on Sat, Feb 23 2013
    • Posts 4
    • Points 60

    Re: Stereoscopic S3D project - left/right eye EDL not working

    Hi Fabrice,

    Is that a full version of Resolve 10? Because lite version doesn`t support stereoscopic sequences.

    Since that time I haven`t found a solution to the problem. As I am still on MC 6.5, I can`t tell if there`s some kind of way out of this in MC 7. In company that I work we switched to Speedgrade CS6 for 3d finishing - but it only support edl`s. We would like to get back to media composer-resolve option, as it seems more robust in dealing with sequences (for Speedgrade sequences have to really be stripped down, even out of speed changes ). Same as you I would like to use AAF, xml`s or other rich metadata formats, but the software side of things is giving me only problems.

     

    Zbig

  • Sat, Nov 16 2013 7:44 AM In reply to

    Re: Stereoscopic S3D project - left/right eye EDL not working

    Hi Zbig,

    Thanks to answer. I have a dongle licence of Resolve 10.0.0.073. 

    The clips are S3D AMA clips in 3D created in MC7 (L,R and audio)

    i try to do it with aaf L, R, SS, both

    I try to convert them into xml (wich is ok with Resolve) but It's also impossible to import MC7 aaf in FCP 7 with Automatic Duck import, it give mad things. 

    The aaf generatd from sequences with these S3D clips are maybe the problem?

    Naturelly, if (and I hope it's just a temporary "if" and will be prompt a "when"...) I find some good light in importing in Resolve 10 a feature film edited in Avid in 3D I will let you know!

     

    Best

    amitiés,

    Fabrice Aragno

     

    MC7.02 / Mac Pro 3.1 / OSX 10.8.5 / 16 go Ram / BM decklink HD extrem 2. / Quadro 4000 + Quadro K5000 / 16 To Raid Hard Drive [view my complete system specs]
  • Wed, Aug 6 2014 3:30 PM In reply to

    Re: Stereoscopic S3D project - left/right eye EDL not working

    Any update on this issue? I still have the same problem generating EDL's, even with the current MC 8.1!

    Mac Pro late 2013 3,5 Ghz 6-Core, 64Gb, OSX 10.10.5, Avid MC 8.4, Blackmagic Ultrastudio Express Macbook Pro retina 2012 15 inch i7, 16Gb, OSX 10.10.5... [view my complete system specs]
  • Wed, Aug 6 2014 6:49 PM In reply to

    • Zbig_
    • Not Ranked
    • Joined on Sat, Feb 23 2013
    • Posts 4
    • Points 60

    Re: Stereoscopic S3D project - left/right eye EDL not working

    If it is about Media Composer to Davincie Resolve 3D workflow - the way I do this now is export only one eye edl (left), and import it into the Resolve. Then I 3D sync the required clips in Resolve, and "Force reconform" on selected clips in timeline and mediapool. It`s time consuming but the 3D aaf route still doesn`t give me good results. The other workaround is matchframing only the one eye (use matchframe on s3d clip in source monitor and it loads 2D leading eye into source monitor), and put 2d clips above the s3d clips, then delete s3d clips(of course duplicate sequence in Avid so you won`t destroy the s3d version). You are left with only 2d clips but the aaf from this kind of sequence import fine in Resolve. Then you do "force reconform" on 3D clips in Davinci Resolve as I described earlier.

    I guess only the high end postproduction facilities can have somewhat comfortable workflow with the help of specialists in the field of stereo 3D, but low/midrange kind of postproduction facilities(the one I`m working at) have to use these kind of workarounds.

    I hope it will change.

    Zbig.

  • Wed, Aug 6 2014 7:50 PM In reply to

    Re: Stereoscopic S3D project - left/right eye EDL not working

    Thanks for your answer. The problem I experience is that in EDL manager monoscopic works fine, but choosing left or right messes things up. We will test if this will do...

    Mac Pro late 2013 3,5 Ghz 6-Core, 64Gb, OSX 10.10.5, Avid MC 8.4, Blackmagic Ultrastudio Express Macbook Pro retina 2012 15 inch i7, 16Gb, OSX 10.10.5... [view my complete system specs]
Page 1 of 1 (9 items)

© Copyright 2011 Avid Technology, Inc.  Terms of Use |  Privacy Policy |  Site Map |  Find a Reseller